首页 > 其他 > 详细

POJ 3663 Costume Party (二分查找)

时间:2015-04-10 22:29:42      阅读:328      评论:0      收藏:0      [点我收藏+]
Costume Party
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12297   Accepted: 4891

Description

It‘s Halloween! Farmer John is taking the cows to a costume party, but unfortunately he only has one costume. The costume fits precisely two cows with a length of (1 ≤ S ≤ 1,000,000). FJ has N cows (2 ≤ N ≤ 20,000) conveniently numbered 1..N; cow i has length Li (1 ≤ Li ≤ 1,000,000). Two cows can fit into the costume if the sum of their lengths is no greater than the length of the costume. FJ wants to know how many pairs of two distinct cows will fit into the costume.

Input

* Line 1: Two space-separated integers: N and S
* Lines 2..N+1: Line i+1 contains a single integer: Li

Output

* Line 1: A single integer representing the number of pairs of cows FJ can choose. Note that the order of the two cows does not matter.

Sample Input

4 6
3
5
2
1

Sample Output

4
给一个序列,取两个数之和小于等于K,问这样的组合有多少个。

二分查找。
先将序列排序,然后对于每个数a,二分查找有多少个数b,使a+b<=k,即二分求上限和下限,因为要去重,每次只需要从a后面的数到序列最后二分。

#include <stdio.h>
#include <algorithm>
using namespace std;
typedef __int64 ll;

const int maxn=20000+10;
int a[maxn];


int main()
{
	int n,s,i,j,t;
	ll ans;
	scanf("%d%d",&n,&s);
	for(i=0;i<n;i++)
		scanf("%d",&a[i]);
	sort(a,a+n);
	ans=0;
	for(i=0;i<n;i++){
		t=upper_bound(a+i+1,a+n,s-a[i])-(a+i+1);	//从i+1开始,这样不会有重复的情况
		ans+=t;
	}
	printf("%I64d\n",ans);
	return 0;
}


POJ 3663 Costume Party (二分查找)

原文:http://blog.csdn.net/u013068502/article/details/44983715

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!