首页 > 其他 > 详细

Sicily 13914. Train Passengers

时间:2015-04-10 22:31:32      阅读:389      评论:0      收藏:0      [点我收藏+]

13914. Train Passengers

Constraints

Time Limit: 1 secs, Memory Limit: 256 MB

Description

The Nordic Company of Passing Carriages is losing money at an alarming rate because most of their trains are empty. However, on some lines the passengers are complaining that they cannot fit in the cars and have to wait for the next train!

The authorities want to fix this situation. They asked their station masters to write down, for a given train, how many people left the train at their station, how many went in, and how many had to wait. Then they hired your company of highly paid consultants to assign properly sized trains to their routes.

You just received the measurements for a train, but before feeding them to your optimisation algorithm you remembered that they were collected on a snowy day, so any sensible station master would have preferred to stay inside their cabin and make up the numbers instead of going outside and counting.

Verify your hunch by checking whether the input is inconsistent, i.e., at every time the number of people in the train did not exceed the capacity nor was below 0 and no passenger waited in vain. The train should start and finish the journey empty, in particular passengers should not wait for the train at the last station.

Input

The first line contains two integers C and n (2 <= n <= 100), the total capacity and the number of stations the train stops in. The next n lines contain three integers each, the number of people that left the train, entered the train, and had to stay at a station. Lines are given in the same order as the train visits each station. All integers including C are between 0 and 109 inclusive.

Output

One line containing one word: possible if the measurements are consistent, impossible otherwise.

Sample Input

样例一:
1 2
0 1 1
1 0 0
样例二:
1 2
1 0 0
0 1 0
样例三:
1 2
0 1 0
1 0 1
样例四:
1 2
0 1 1
0 0 0

Sample Output

样例一:
possible
样例二:
impossible
样例三:
impossible
样例四:
impossible

Problem Source

2015年每周一赛第四场

#include <stdio.h>

int main() {
	bool possible = true;
	int c, n, m = 0, l, e, w;
	scanf("%d%d", &c, &n);
	while (n && n--) {
		scanf("%d%d%d", &l, &e, &w);
		if (!(0 <= l && l <= m)) possible = false;
		m -= l;
		if (!(0 <= e && e <= c - m)) possible = false;
		m += e;
		if (0 > w || (c > m && w > 0)) possible = false;
	}
	while (n--) scanf("%d%d%d", &l, &e, &w);
	printf(possible && !m ? "possible\n" : "impossible\n");
	return 0;
}

Sicily 13914. Train Passengers

原文:http://blog.csdn.net/u012925008/article/details/44983217

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!