首页 > 其他 > 详细

HDU5203 Rikka with wood sticks

时间:2015-04-12 09:16:25      阅读:343      评论:0      收藏:0      [点我收藏+]

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:


Yuta have a wood stick of length n技术分享 which consists of n技术分享 linked sticks of length 1技术分享. So it has n?1技术分享 connection points. Yuta finds that some sticks of length 1技术分享 of the wood stick are not strong. So he wants to choose three different connection points to cut it into four wood sticks and only one of them contains wood sticks which are not strong. And Yuta wants to minimize the length of this piece which contains bad wood sticks. Besides, Rikka wants to use the other three wood sticks to make a triangle. Now she wants to count the number of the ways to cut the wood sticks which can make both Yuta and herself happy.


It is too difficult for Rikka. Can you help her?
 

Input
This problem has multi test cases (no more than 20技术分享). For each test case, The first line contains two numbers n,m(1n1000000,1m1000)技术分享. The next line contains m numbers (some of them may be same) – the position of each wood sticks which is not strong.
 

Output
For each test cases print only one number – the ways to cut the wood sticks.
 

Sample Input
6 1 3 5 1 3
 

Sample Output
2 0
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:  5205 5204 5201 5200 5199 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>


#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef long long ll;

#define fre(i,a,b)  for(i = a; i <b; i++)
#define free(i,b,a) for(i = b; i >= a;i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define ssf(n)      scanf("%s", n)
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N 400

int n,m;
int le,ri;
int a,b;

void fdd()
{
   a=a+b;
   int i,j;
   ll ans=0;
   for(i=1;i*2<a;i++)
   {
   	 int t=a-i-i;
   	 t/=2;
   	 t++;
   	 int to=a-i-t;
   	 if(to<t) continue;
   	 if(t==0) continue;
   	 ans+=to-t+1;

   }
  pf("%I64d\n",ans);
}

int judge(int x,int y,int z)
{

    if(x+y<=z||x+z<=y) return 0;
    return 1;
}

void solve()
{
    int i,j;
    if(a==0||b==0)
	{
		fdd();
		return ;
	}
    ll ans=0;
    if(a>b) swap(a,b);

    for(i=1;i<b;i++)
	{
		if(judge(a,i,b-i))
			ans++;

	}
    printf("%I64d\n",ans);
}

int main()
{
   int i,j;
   while(~scanf("%d%d",&n,&m))
   {
   	le=INF;
    ri=-1;
    int x;
    while(m--)
	{
		sf(x);
		le=min(le,x);
		ri=max(ri,x);
	}
	 a=le-1;
	 b=n-ri;

	 if(a==b)
	 {
	 	pf("0\n");
	 	continue;
	 }
	
	 solve();
   }
   return 0;

}

/*

8 1
1

*/






HDU5203 Rikka with wood sticks

原文:http://blog.csdn.net/u014737310/article/details/44999839

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!