首页 > 其他 > 详细

杭电5123 who is the best?

时间:2015-04-12 12:07:25      阅读:350      评论:0      收藏:0      [点我收藏+]
Problem Description
There are N people want to choose the best person. Each person select the best person ai, .John wants to know that who received the most number of votes.
Input
The first line contains a single integer T(1≤T≤50),indicating the number of test cases.
Each test case begins with an integer N(1≤N≤100),indicating the number of person.
Next N lines contains an integer ai(1≤ai≤N).
Output
For each case, output an integer means who is the best person. If there are multiple answers, print the minimum index.
Sample Input
2
10
1
2
3
4
5
6
7
8
9
10
5
3
3
3
3
3
Sample Output
1
3

思路:这是一道,选票问题,记录出现的次数就行

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    int test,n,k;
    int a[120];
    cin>>test;
    while(test--)
    {
        cin>>n;
        memset(a,0,sizeof(a));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&k);
            a[k]++;
        }
        int max=0,num;
        for(int i=1;i<=n;i++)
        {
            if(max<a[i])
            {
                max=a[i];
                num=i;
            }
        }
        printf("%d\n",num);
    }
    return 0;
}


杭电5123 who is the best?

原文:http://blog.csdn.net/qq_qingtian/article/details/45008033

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!