首页 > 其他 > 详细

HDOJ刷题(1093)

时间:2015-04-12 17:51:08      阅读:252      评论:0      收藏:0      [点我收藏+]

A+B for Input-Output Practice (V)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 55226    Accepted Submission(s): 37126

Problem Description
Your task is to calculate the sum of some integers.
 
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
 
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 
Sample Input
2 4 1 2 3 4 5 1 2 3 4 5
 
Sample Output
10 15
 

程序(已经accepted):
#include <stdio.h>

int main()
{
    int line, number, sum, n;
    scanf("%d", &line);
    while(line--)
    {
        sum = 0;
        scanf("%d", &n);
        while(n--)
        {
            scanf("%d", &number);
            sum += number;
        }
        printf("%d\n", sum);
    }
    return 0;
}
运行时间:
技术分享

HDOJ刷题(1093)

原文:http://blog.csdn.net/xumesang/article/details/45010347

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!