首页 > Web开发 > 详细

POJ 题目3694 Network(tarjan,LCA,求桥)

时间:2015-04-17 11:41:28      阅读:421      评论:0      收藏:0      [点我收藏+]
Network
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 7179   Accepted: 2600

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can‘t be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ AB ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ ABN), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0

Source

2008 Asia Hefei Regional Contest Online by USTC

给出一张图,Q个询问,每个询问都是在前面询问的基础上,每个询问连一条边,问现在还有几个桥。

ac代码

#include<iostream>
#include<math.h>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<vector>
#include<queue>
#include<map>
#include<set>
using namespace std;
#define B(x) (1<<(x))
typedef long long ll;
void cmax(int& a,int b){ if(b>a)a=b; }
void cmin(int& a,int b){ if(b<a)a=b; }
const int oo=0x3f3f3f3f;
const int MOD=1000000007;
const int maxn=110000;
const int maxm=210000;
struct EDGE{
    int v,next,c,f;
}E[maxm<<1];
int head[maxn],tol;
int low[maxn],dfn[maxn];
int isbridge[maxn],fa[maxn];
int g_cnt,bcnt;

void Init(){
    memset(head,-1,sizeof head);
    tol=0;
    memset(low,0,sizeof low);
    memset(dfn,0,sizeof dfn);
    memset(isbridge,0,sizeof isbridge);
    g_cnt=bcnt=0;
}

void add_edge(int u,int v){
    E[tol].v=v;
    E[tol].next=head[u];
    head[u]=tol++;
}

void Tarjan(int u,int pre){
    dfn[u]=low[u]=++g_cnt;
    for(int i=head[u];i!=-1;i=E[i].next){
        int v=E[i].v;
        if(v==pre)continue;
        if(!dfn[v]){
            fa[v]=u;
            Tarjan(v,u);
            if(low[v]<low[u])
                low[u]=low[v];
            if(low[v]>dfn[u]){
                bcnt++;
                isbridge[v]=1;
            }
        }else if(dfn[v]<low[u])
            low[u]=dfn[v];
    }
}

void LCA(int u,int v){
    if(dfn[u]<dfn[v])swap(u,v);
    while(dfn[u]>dfn[v]){
        if(isbridge[u])bcnt--;
        isbridge[u]=0;
        u=fa[u];
    }
    while(u!=v){
        if(isbridge[u])bcnt--;
        if(isbridge[v])bcnt--;
        isbridge[u]=isbridge[v]=0;
        u=fa[u];
        v=fa[v];
    }
}

int main(){
    //freopen("E:\\read.txt","r",stdin);
    int n,m,u,v,Q;
    int cas=1;
    while(scanf("%d %d",&n,&m)!=EOF){
        if(n==0&&m==0)break;
        Init();
        for(int i=1;i<=m;i++){
            scanf("%d %d",&u,&v);
            add_edge(u,v);
            add_edge(v,u);
        }
        fa[1]=1;
        Tarjan(1,-1);
        scanf("%d",&Q);
        printf("Case %d:\n",cas++);
        while(Q--){
            scanf("%d %d",&u,&v);
            LCA(u,v);
            printf("%d\n",bcnt);
        }
        puts("");
    }
    return 0;
}


 

题目大意:

POJ 题目3694 Network(tarjan,LCA,求桥)

原文:http://blog.csdn.net/yu_ch_sh/article/details/45081339

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!