首页 > 其他 > 详细

HDU2010省赛集训队选拔赛(校内赛) G

时间:2015-04-21 14:41:57      阅读:136      评论:0      收藏:0      [点我收藏+]

lazy gege

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 948    Accepted Submission(s): 361



Problem Description
Gege hasn‘t tidied his desk for long,now his desk is full of things.
This morning Gege bought a notebook,while to find somewhise to put it troubles him.
He wants to tidy a small area of the desk, leaving an empty area, and put the notebook there, the notebook shouldn‘t fall off the desk when putting there.
The desk is a square and the notebook is a rectangle, area of the desk may be smaller than the notebook.
here‘re two possible conditions:
技术分享

Can you tell Gege the smallest area he must tidy to put his notebook?
 

Input
T(T<=100) in the first line is the case number.
The next T lines each has 3 real numbers, L,A,B(0< L,A,B <= 1000).
L is the side length of the square desk.
A,B is length and width of the rectangle notebook.
 

Output
For each case, output a real number with 4 decimal(printf("%.4lf",ans) is OK), indicating the smallest area Gege should tidy.
 

Sample Input
3 10.1 20 10 3.0 20 10 30.5 20.4 19.6
 

Sample Output
25.0000 9.0000 96.0400
 

Author
madfrog
 

Source
HDU2010省赛集训队选拔赛(校内赛)

题意: 求一个矩形放在正方形的桌子上,不掉落,所覆盖的最小面积
题解: 要使矩形不掉落,只需矩形的重心在桌子上即可,然后要求覆盖的最小面积,则分类讨论下就行了. (很容易想的)具体看代码吧!

AC代码:
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
#include <cmath>
#define eps 1e-8

using namespace std;
const int MAXN = 1e3 + 100;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int>P;

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        double d,a,b,ans;
        scanf("%lf %lf %lf",&d,&a,&b);
        if(a > b) swap(a,b);
        double mid = sqrt((double)2) / 2 * d;
        if(mid + eps >= a / 2) ans = a * a / 4.0;
        else if(mid * 2 < a / 2 + eps) ans = d * d;
        else
        {
            double r = mid * 2.0 - a / 2;
            ans = d * d - r * r;
        }
        printf("%.4lf\n",ans);
    }
    return 0;
}

 

HDU2010省赛集训队选拔赛(校内赛) G

原文:http://blog.csdn.net/zsgg_acm/article/details/45169193

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!