首页 > 其他 > 详细

hdu4734F(x)

时间:2015-04-24 22:43:54      阅读:290      评论:0      收藏:0      [点我收藏+]

F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2188    Accepted Submission(s): 827


Problem Description
For a decimal number x with n digits (AnAn-1An-2 ... A2A1), we define its weight as F(x) = An * 2n-1 + An-1 * 2n-2 + ... + A2 * 2 + A1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 109)
 

Output
For every case,you should output "Case #t: " at first, without quotes. Thet is the case number starting from 1. Then output the answer.
 

Sample Input
3 0 100 1 10 5 100
 

Sample Output
Case #1: 1 Case #2: 2 Case #3: 13
 

Source
2013 ACM/ICPC Asia Regional Chengdu Online

 我们定义十进制数x的权值为f(x) = a(n)*2^(n-1)+a(n-1)*2(n-2)+...a(2)*2+a(1)*1,a(i)表示十进制数x中第i位的数字。


  题目给出a,b,求出0~b有多少个不大于f(a)的数。

第一次独立用递归完成数位dp

#include<map>
#include<string>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#include<bitset>
#include<climits>
#include<list>
#include<iomanip>
#include<stack>
#include<set>
using namespace std;
int dp[20][(1<<9)*9],bit[20];
int dfs(int len,int sum,bool e)
{
	if(len==0)
		return sum>=0;
	if(!e&&dp[len][sum]!=-1)
		return dp[len][sum];
	int n=e?bit[len]:9,ans=0;
	for(int i=0;i<=n;i++)
	{
		int t=sum-i*(1<<len-1);
		if(t>=0)
			ans+=dfs(len-1,t,e&&i==n);
		else
			break;
	}
	return e?ans:dp[len][sum]=ans;
}
int cg(int x)
{
	int tail=0;
	while(x)
	{
		bit[++tail]=x%10;
		x/=10;
	}
	return tail;
}
int cnt(int x)
{
	int ans=0;
	for(int i=cg(x);i>0;i--)
		ans+=(1<<i-1)*bit[i];
	return ans;
}
int main()
{
	memset(dp,-1,sizeof(dp));
	int T;
	cin>>T;
	for(int cs=1;cs<=T;cs++)
	{
		int a,b;
		cin>>a>>b;
		int sum=cnt(a),ans=dfs(cg(b),sum,1);
		cout<<"Case #"<<cs<<": "<<ans<<endl;
	}
}


hdu4734F(x)

原文:http://blog.csdn.net/stl112514/article/details/45252425

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!