首页 > 其他 > 详细

POJ 2407 Relatives(欧拉函数)

时间:2015-04-25 12:12:34      阅读:152      评论:0      收藏:0      [点我收藏+]
Relatives
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11801   Accepted: 5780

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

#include <stdio.h>
#include <string.h>

int solve(int n){
	int i,res=n;
	for(i=2;i*i<n;i++)
		if(n%i==0){
			res-=res/i;
			do{
				n/=i;
			}while(n%i==0);
		}
	if(n>1)
		res-=res/n;
	return res;
}

int main()
{
	int n;
	while(scanf("%d",&n),n)
		printf("%d\n",solve(n));
	return 0;
}


POJ 2407 Relatives(欧拉函数)

原文:http://blog.csdn.net/u013068502/article/details/45269059

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!