首页 > 其他 > 详细

Hdoj 1432 Lining Up 【叉积】

时间:2015-04-25 23:59:45      阅读:477      评论:0      收藏:0      [点我收藏+]

Lining Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1094    Accepted Submission(s): 307


Problem Description
``How am I ever going to solve this problem?" said the pilot. 


Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number? 

Your program has to be efficient! 
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer on a line by itself indicating the number of points, followed by N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. No pair will occur twice in one test case. 

 

Output
For each test case, the output consists of one integer representing the largest number of points that all lie on one line, one line per case.
 

Sample Input
5 1 1 2 2 3 3 9 10 10 11
 

Sample Output
3

题意:给出一些坐标,问有多少各点在同一条直线上

策略:共线向量叉积为0; 叉积公式 例如 a (x1, y1), b(x2, y2)  a*b = x1*y2-x2*y1

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
const int M = 750;
using namespace std;

struct node{
    int x, y;
}s[M];

bool f(node a, node b, node c){
    return ((a.x-c.x)*(b.y-c.y)-(a.y-c.y)*(b.x-c.x) == 0); //
}

int main(){
    int n;
    while(scanf("%d", &n) == 1){
        for(int i = 0; i < n; ++ i){
            scanf("%d%d", &s[i].x, &s[i].y);
        }
        int ans = 0, cou = 0;
        for(int i = 0; i < n; ++ i){
            for(int j = i+1; j < n; ++ j){
                cou = 0;
                for(int k = j+1; k < n; ++ k){
                    if(f(s[i], s[j], s[k])) ++cou;
                }
                ans = max(ans, cou);
            }
        }
        printf("%d\n", ans+2);
    }
    return 0;
}

Hdoj 1432 Lining Up 【叉积】

原文:http://blog.csdn.net/shengweisong/article/details/45278809

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!