首页 > 其他 > 详细

hdoj 1071 The area

时间:2015-04-28 22:29:20      阅读:320      评论:0      收藏:0      [点我收藏+]

The area

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8388    Accepted Submission(s): 5888


Problem Description
Ignatius bought a land last week, but he didn‘t know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.

技术分享
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 

 

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 

 

Sample Input
2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222
 

 

Sample Output
33.33
40.69
 
就是一道数学题,做题的时候看错了一个坐标  结果看了好长时间没发现  坑~~~~
#include<stdio.h>
#include<math.h>
int main()
{
	int N;
	double a,b,c,d,k,x1,y1,x2,y2,x3,y3,s;
	scanf("%d",&N);
	while(N--)
	{
		s=0;
		scanf("%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3);
		a=((y1-y3)*(x1-x2)-(y1-y2)*(x1-x3))/((x1*x1-x3*x3)*(x1-x2)-(x1*x1-x2*x2)*(x1-x3));	
		d=((y1-y3)-a*(x1*x1-x3*x3))/(x1-x3);
		c=y1-a*x1*x1-d*x1;		
		k=(y2-y3)/(x2-x3);
		b=y3-k*x3;
		s=((a*x3*x3*x3)/3+((d-k)*x3*x3)/2+(c-b)*x3)-((a*x2*x2*x2)/3+((d-k)*x2*x2)/2+(c-b)*x2);
		printf("%.2lf\n",s);
	}
	return 0;
}

  

hdoj 1071 The area

原文:http://www.cnblogs.com/tonghao/p/4463942.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!