首页 > 其他 > 详细

1030. Travel Plan (30) PAT

时间:2014-03-15 21:55:09      阅读:659      评论:0      收藏:0      [点我收藏+]

A traveler‘s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40

AC代码:
//最短路径问题的变异版本,本代码采用的迪杰斯特拉算法,注意重边的情况

#include<stdio.h>
#include<stack>
using namespace std;
#define N 500
#define INF 1000000000

int dist[N][N], price[N][N]; //使用邻接矩阵存储
int set[N]; //标志是否被访问过
int dis[N], pri[N]; //存放起点到各点的最短距离和花费
int path[N]; //存储起点到各个点最短路径中的倒数第二个点
int sta[1000]; //利用数组模拟棧进行路径输出

int main() {
	//freopen("in.txt","r",stdin);
	int n, m;
	while(scanf("%d %d",&n,&m)!=EOF && (n||m)) {
		int s, t;
		scanf("%d %d",&s,&t);
		int i, j;
		int a, b, d, p;
		for(i=0; i<n; i++) {
			for(j=1; j<=n; j++) { //初始化各边的距离和花费最大
				dist[i][j] = dist[j][i] = INF;
				price[i][j] = price[j][j] = INF;
			}
		}
		while(m--) {
			scanf("%d %d %d %d",&a,&b,&d,&p);
			if(dist[a][b] > d) { //当有重边时,更新相关信息
				dist[a][b] = dist[b][a] = d;
				price[a][b] = price[b][a] = p;
			}
			if(dist[a][b] == d && p<price[a][b]) {
				dist[a][b] = dist[b][a] = d;
				price[a][b] = price[b][a] = p;
			}
		}	
		for(i=0; i<n; i++) { //初始化起点到各点的最短距离和花费以及访问标志
			dis[i] = dist[s][i];
			pri[i] = price[s][i];
			set[i] = 0;
			if(dis[i]<INF)
				path[i] = s; //若起点到该点存在边
			else
				path[i] = -1;
		}
		set[s] = 1, path[s] = -1; //起点标志为1,表示已访问
		for(i=0; i<n; i++) {
			int pre_sd = INF; //存储未被访问点到起点距离的最小值
			int midp; //存储未被访问点到起点距离的最小的点
			for(j=0; j<n; j++) {
				if(set[j]==0 && dis[j]<pre_sd) {
					pre_sd = dis[j];
					midp = j;
				}
			}
			if(midp == t) //若已访问到题目给定的终点,退出循环
				break;
			set[midp] = 1; //标志为1,表示已访问
			for(j=0; j<n; j++) {
				if(set[j]==0 ) { //以midp为中介点,更新各未被访问点到起点的距离和花费
					if(dis[midp]+dist[midp][j] < dis[j]) {
						dis[j] = dis[midp]+dist[midp][j];
						pri[j] = pri[midp]+price[midp][j];
						path[j] = midp; //将midp作为最短路径上倒数第二个节点
					}
					if(dis[midp]+dist[midp][j] == dis[j] && pri[j] > pri[midp]+price[midp][j]) {
						dis[j] = dis[midp]+dist[midp][j];
						pri[j] = pri[midp]+price[midp][j];
						path[j] = midp;
					}
				}
			}
		}
		
		int tmp = t;
		int top = 0;
		while(path[tmp]!=-1) {
			sta[top++] = path[tmp];
			tmp = path[tmp];
		}
		while(top>0) {
			printf("%d ",sta[--top]);
		}
		printf("%d ",t); //输出终点

		printf("%d %d\n",dis[t],pri[t]);
	}

	return 0;
}


1030. Travel Plan (30) PAT,布布扣,bubuko.com

1030. Travel Plan (30) PAT

原文:http://blog.csdn.net/zjfclh/article/details/21296283

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!