首页 > 其他 > 详细

The area面积计算

时间:2014-03-15 22:41:17      阅读:647      评论:0      收藏:0      [点我收藏+]

Problem Description

Ignatius bought a land last week, but he didn‘t know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.

bubuko.com,布布扣

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).

Output

For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.

Sample Input

2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222

Sample Output

33.33
40.69
///////抽象出公式
#include <iostream>
using namespace std;
int main()
{   int t;
    double x1,y1,x2,y2,x3,y3,a,k,s;
    cin>>t;
    while(t--)
    { cin>>x1>>y1>>x2>>y2>>x3>>y3;
      a=(y2-y1)/((x2-x1)*(x2-x1));
      k=(y2-y3)/(x2-x3);
      s=a/3*(x3*x3*x3-x2*x2*x2)+(a*x1*x1+k*x3+y1-y3)*(x3-x2)+0.5*(2*a*x1+k)*(x2*x2-x3*x3);
       printf("%.2f\n",s);
    }
return 0;
}


The area面积计算,布布扣,bubuko.com

The area面积计算

原文:http://blog.csdn.net/rememberautumn/article/details/21296195

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!