首页 > 其他 > 详细

CSU 1617: Itself is Itself(强连通缩点)思想转换到图论

时间:2015-05-10 18:56:59      阅读:153      评论:0      收藏:0      [点我收藏+]

1617: Itself is Itself

Time Limit: 6 Sec  Memory Limit: 128 MB
Submit: 21  Solved: 4
[Submit][Status][Web Board]

Description

Zuosige always has bad luck. Recently, he is in hospital because of pneumonia. While he is taking his injection, he feels extremely bored. However, clever Zuosige comes up with a new game.

Zuosige writes an integer n and a polynomial function:
P(x) = (a0+a1*x+a2*x2+…+am*xm) mod n.
He wants to know how many subsets of set {0, 1, 2, … , n-2, n-1} satisfies following property: the range of P(x) from the subset is itself. Pay attention to that empty set is also a valid subset.

Input

The first line contains one integer T, indicating the number of test cases.
In one test case, there are two lines.
In the first line, there are two integers n and m (1<=n<=10000, 1<=m<=1000).
In the second line, there m+1 integers. The i-th integer indicating ai-1 (0<=ai<=10000).

Output

For each test case, output an integer in a line indicating the answer. The answer can be very large, so you need just output the answer mod 1e9+7.

Sample Input

2
3 1
0 1
3 1
1 1

Sample Output

8
2

HINT

Source

#include<stdio.h>
#include<vector>
#include<string.h>
using namespace std;
#define modd 1000000007
const int N= 10005;

int n,c[N];
int dfn[N],low[N],Stack[N],flag[N],vist[N],num[N],top,deep,tn;
vector<int>mapt1[N];

void init()
{
    for(int i=0;i<=n;i++)
    {
        mapt1[i].clear();
        dfn[i]=0;
        num[i]=0;
        vist[i]=0;
    }
    tn=top=deep=0;
}
int tt;
void tarjan(int u)
{
    vist[u]=tt;
    deep++;
    dfn[u]=low[u]=deep;
    Stack[++top]=u;

    int len=mapt1[u].size();
    for(int i=0;i<len;i++)
    {
        int v=mapt1[u][i];

        if(vist[v]==0)
        {
            tarjan(v);
            if(low[u]>low[v])
                low[u]=low[v];
        }
        else if(vist[v]==tt&&low[u]>dfn[v])//注意vist[v]==tt
            low[u]=dfn[v];
    }
    if(low[u]==dfn[u])
    {
        tn++;
        while(u!=Stack[top])
        {
            flag[Stack[top]]=tn; num[tn]++;top--;
        }
        flag[Stack[top]]=tn; num[tn]++; top--;
    }
}
int out[N];
int rebuilMap()//用强连通缩点,
{
    tt=0;
    for(int i=0;i<n;i++)
        if(vist[i]==0)
        {
            tt++;
            tarjan(i);
        }

    memset(out,0,sizeof(out));
//缩点后的图无 有向环
    for(int i=0;i<n;i++)
    {
        int u=flag[i];
        for(int j=0;j<mapt1[i].size();j++)
        {
            int v=flag[mapt1[i][j]];
            if(u==v)
                continue;
            out[u]++;
        }
    }
    int number=0;
    for(int i=1;i<=tn;i++)
        if(out[i]==0)
            number++;
    return number;
}
int main()
{
    int T,m;

    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        for(int i=0;i<=m;i++){
            scanf("%d",&c[i]);
            c[i]%=n;
        }

        init();
        for(int i=0;i<n;i++)
        {
            int ansa=c[0],x=i;
            for(int j=1;j<=m;j++){
                    ansa=(ansa+c[j]*x)%n;
                    x=(x*i)%n;
            }
            if(i!=ansa)
            mapt1[i].push_back(ansa);
        }

        int number=rebuilMap();
        long long ans = 1;
        for(int i=1;i<=number;i++)
            ans=(ans*2)%1000000007;
        printf("%lld\n",ans);
    }
    return 0;
}


CSU 1617: Itself is Itself(强连通缩点)思想转换到图论

原文:http://blog.csdn.net/u010372095/article/details/45623311

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!