首页 > 其他 > 详细

题目1002:Grading 2011年浙江大学计算机及软件工程研究生机试真题

时间:2014-03-17 02:04:48      阅读:360      评论:0      收藏:0      [点我收藏+]
题目描述:

    Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other, a judge is invited to make the final decision. Now you are asked to write a program to help this process.
    For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:
    ? A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem‘s grade will be the average of G1 and G2.
    ? If the difference exceeds T, the 3rd expert will give G3.
    ? If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem‘s grade will be the average of G3 and the closest grade.
    ? If G3 is within the tolerance with both G1 and G2, then this problem‘s grade will be the maximum of the three grades.
    ? If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:

    Each input file may contain more than one test case.
    Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:

    For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18
样例输出:
14.0

AC代码:
//本题不难,看清题目分情况讨论就行,但有几个地方需要注意;
//1.abs()在头文件stdlib.h里,fabs()在math.h里
//2.读入的是整数,输出的是格式化的浮点数

#include<stdio.h>
#include<math.h>

int main() {
	//freopen("in.txt","r",stdin);
	int P, T, G1, G2, G3, GJ;
	double grade;
	while(scanf("%d %d %d %d %d %d",&P,&T,&G1,&G2,&G3,&GJ)!=EOF) {
		if((int)fabs(G1-G2)<=T)
			grade = (G1+G2)/2.0; //注意除数是2.0,不然‘/‘就成取整符号而不是除号了
		else {
			int t1, t2;
			t1 = (int) fabs(G3-G1); //fabs的返回值的double,要强制转换为int
			t2 = (int) fabs(G3-G2);
			if((t1<=T && t2>T) || (t2<=T && t1>T)) {
				if(t1 < t2)
					grade = (G3+G1)/2.0;
				else
					grade = (G3+G2)/2.0;
			}
			if(t1<=T && t2<=T) {
				int max;
				max = G1 > G2 ? G1 : G2;
				max = max > G3 ? max : G3;
				grade = max;
			}
			if(t1>T && t2>T)
				grade = GJ;
		}
		printf("%.1lf\n",grade); //注意输出格式
	}

	return 0;
}


题目1002:Grading 2011年浙江大学计算机及软件工程研究生机试真题,布布扣,bubuko.com

题目1002:Grading 2011年浙江大学计算机及软件工程研究生机试真题

原文:http://blog.csdn.net/zjfclh/article/details/21342413

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!