首页 > 其他 > 详细

Q - Phalanx HDU 2859 ( dp )

时间:2015-05-17 15:17:50      阅读:239      评论:0      收藏:0      [点我收藏+]

Q - Phalanx
Time Limit:5000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status Practice HDU 2859

Description
Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC.
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position.
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs.
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix:
cbx
cpb
zcc


Input
There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.


Output
Each test case output one line, the size of the maximum symmetrical sub- matrix.


Sample Input

3
abx
cyb
zca
4
zaba
cbab
abbc
cacq
0



Sample Output

3

3

搜索每一个位置作为对角线的情况下能够到达的最大值

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1005;
int dp[maxn][maxn];
char s[maxn][maxn];
int N,ans;
void work(int x,int y)//枚举每一个点的上方与右边能够到的最大值
{
    if(x==0||y==N-1){
        dp[x][y]=1;
        return ;
    }
    int i=x,j=y;
    while(i>=0&&j<N&&s[i][y]==s[x][j]){
        i--;j++;
    }
    int len=x-i;
    if(len>=dp[x-1][y+1]+1)dp[x][y]=dp[x-1][y+1]+1;
    else dp[x][y]=len;
    ans=max(ans,dp[x][y]);
}
int main()
{
    while(scanf("%d",&N)&&N){
        for(int i=0;i<N;i++){
            scanf("%s",s[i]);
        }
        ans=1;
        for(int i=0;i<N;i++)
        for(int j=0;j<N;j++){
            work(i,j);
        }
        printf("%d\n",ans);
    }
    return 0;
}














Q - Phalanx HDU 2859 ( dp )

原文:http://blog.csdn.net/u013167299/article/details/45788735

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!