int sg[10001];
int f[101];
// f[]为可以取的石子个数,k为f[]的长度
sort(f,f+K); // f[]必须是从小到大排列
memset(sg,-1,sizeof(sg)); // sg[0]=0, 最小值为0 ,初始化
int Get_SG(int x,int k) // 计算sg[x]
{
int visited[101]={0};
if(sg[x] != -1) return sg[x]; // 同一个集合, 如果已经计算过的sg[x], 可以重复利用
if(x<f[0]) return sg[x]=0;
for(int j=0; f[j]<=x && j<k; j++) // visited 最多更改k次
visited[Get_SG(x-f[j],k)]=1;
for(int i=0;;i++)
if(!visited[i]) return sg[x]=i;
}
题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1536
S-Nim
Time Limit: 5000/1000 MS
(Java/Others) Memory Limit: 65536/32768 K
(Java/Others)
Total Submission(s):
3845 Accepted Submission(s):
1685
Problem Description
Arthur and his sister Caroll have been
playing a game called Nim for some time now. Nim is played as
follows:
The starting position has a number
of heaps, all containing some, not necessarily equal, number of
beads.
The players take turns chosing a heap and
removing a positive number of beads from it.
The
first player not able to make a move, loses.
Arthur and
Caroll really enjoyed playing this simple game until they recently
learned an easy way to always be able to find the best
move:
Xor the number of beads in the heaps in
the current position (i.e. if we have 2, 4 and 7 the xor-sum will be
1 as 2 xor 4 xor 7 = 1).
If the xor-sum is 0, too
bad, you will lose.
Otherwise, move such that the
xor-sum becomes 0. This is always possible.
It is quite
easy to convince oneself that this works. Consider these
facts:
The player that takes the last bead
wins.
After the winning player‘s last move the
xor-sum will be 0.
The xor-sum will change after
every move.
Which means that if you make sure that the
xor-sum always is 0 when you have made your move, your opponent will
never be able to win, and, thus, you will
win.
Understandibly it is no fun to play a game when
both players know how to play perfectly (ignorance is bliss).
Fourtunately, Arthur and Caroll soon came up with a similar game,
S-Nim, that seemed to solve this problem. Each player is now only
allowed to remove a number of beads in some predefined set S, e.g.
if we have S =(2, 5) each player is only allowed to remove 2 or 5
beads. Now it is not always possible to make the xor-sum 0 and,
thus, the strategy above is useless. Or is it?
your job
is to write a program that determines if a position of S-Nim is a
losing or a winning position. A position is a winning position if
there is at least one move to a losing position. A position is a
losing position if there are no moves to a losing position. This
means, as expected, that a position with no legal moves is a losing
position.
Input
Input consists of a number of test cases.
For each test case: The first line contains a number k (0 < k ≤
100 describing the size of S, followed by k numbers si (0 < si ≤
10000) describing S. The second line contains a number m (0 < m ≤
100) describing the number of positions to evaluate. The next m
lines each contain a number l (0 < l ≤ 100) describing the number
of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of
beads in the heaps. The last test case is followed by a 0 on a line
of its own.
Output
For each position: If the described
position is a winning position print a ‘W‘.If the described position
is a losing position print an ‘L‘. Print a newline after each test
case.
Sample Input
2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0
Sample Output
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<set>
#define Inf 0x7fffffff // 0x 是数字0,而不是字母o
#define N 10001
using namespace std;
int sg[N],K;
int f[101];
int Get_SG(int x)
{
int visited[101]={0};
if(sg[x] != -1) return sg[x]; // 同一个集合, 如果已经计算过的sg[x], 可以重复利用
if(x<f[0]) return sg[x]=0;
for(int j=0; f[j]<=x && j<K; j++)
visited[Get_SG(x-f[j])]=1;
for(int i=0;;i++)
if(!visited[i]) return sg[x]=i;
}
int main(){
int l,temp,x,m,Max;
while(scanf("%d",&K) && K)
{
int x=0,Max=0;
for(int i=0;i<K;i++)
scanf("%d",&f[i]);
sort(f,f+K);
scanf("%d",&m);
memset(sg,-1,sizeof(sg));
while(m--)
{
scanf("%d",&l);
x=0;
for(int i=0 ;i<l; i++)
{
scanf("%d",&temp);
x^=Get_SG(temp);
}
if(x) printf("W");
else printf("L");
}
printf("\n");
}
return 0;
}