首页 > 系统服务 > 详细

Eclipse下安装Scala2.10.4插件

时间:2015-06-07 21:47:19      阅读:68296      评论:0      收藏:0      [点我收藏+]

标签:spark   eclipse   scala插件   

   Spark编译的目前都是基于Scala 2.10.4的,安装Scala插件版本也是选择2.10.4,否则eclipse会报spark的jar包和scala版本不兼容的错误.

   Scala IDE for Eclipse 不同的Eclipse版本对应插件也的不同

   下载地址:http://scala-ide.org/download/prev-stable.html

   
Eclipse 3.8-4.3 (Juno and Kepler)

For Scala 2.11.2
http://download.scala-ide.org/sdk/helium/e38/scala211/stable/site

For Scala 2.10.4
http://download.scala-ide.org/sdk/helium/e38/scala210/stable/site

   

   选择Eclipse4.2 Juno进行插件安装

   在Eclipse中选择Help->Install new Software

技术分享

    

    添加插件下载链接安装后,会提示重新启动Eclipse

    新建Scala Project工程Test,测试是否可正确使用,在project工程里除了加载JRE Library,还会加载Scala 2.10.4的相关libray

object Testd {
  def main(args: Array[String]): Unit = {
     val array = Array("scala 2.10.4","spark 1.1.0")
     array.foreach(println)
  }
}

    运行跟Java程序一样,被编译成class文件在JVM中运行

scala 2.10.4
spark 1.1.0


本文出自 “脚踏实地,仰望星空” 博客,请务必保留此出处http://xubcing.blog.51cto.com/3502962/1659428

Eclipse下安装Scala2.10.4插件

标签:spark   eclipse   scala插件   

原文:http://xubcing.blog.51cto.com/3502962/1659428

(1)
(3)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号