首页 > 其他 > 详细

PAT: 1054. The Dominant Color (20)

时间:2014-03-21 23:51:47      阅读:764      评论:0      收藏:0      [点我收藏+]

1054. The Dominant Color (20)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard

Behind the scenes in the computer‘s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
AC代码:
//此题用map再适合不过了

#include<stdio.h>
#include<map>
using namespace std;

int main()
{
    //freopen("in.txt","r",stdin);
    int m, n;
	map<int,int> dc;
	map<int,int>::iterator it; //定义迭代器
	while(scanf("%d %d",&m,&n)!=EOF) {	
		int i, j, a;
		for(i=0; i<n; i++) {
			for(j=0; j<m; j++) {
				scanf("%d",&a);
				dc[a]++; //用数组方式进行插入
			}
		}
		for(it=dc.begin(); it!=dc.end(); it++) {
			if(it->second > n*m/2) {
				//A strictly dominant color takes more than half of the total area.
				printf("%d\n",it->first);
				break;
			}
		}
	}

    return 0;
}


PAT: 1054. The Dominant Color (20),布布扣,bubuko.com

PAT: 1054. The Dominant Color (20)

原文:http://blog.csdn.net/zjfclh/article/details/21749019

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!