首页 > 其他 > 详细

hdoj 1977 Consecutive sum II

时间:2015-06-15 23:46:13      阅读:267      评论:0      收藏:0      [点我收藏+]

Consecutive sum II

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2523    Accepted Submission(s): 1219


Problem Description
Consecutive sum come again. Are you ready? Go ~~
1    = 0 + 1
2+3+4    = 1 + 8
5+6+7+8+9  = 8 + 27

You can see the consecutive sum can be representing like that. The nth line will have 2*n+1 consecutive numbers on the left, the first number on the right equal with the second number in last line, and the sum of left numbers equal with two number’s sum on the right.
Your task is that tell me the right numbers in the nth line.
 

 

Input
The first integer is T, and T lines will follow.
Each line will contain an integer N (0 <= N <= 2100000).
 

 

Output
For each case, output the right numbers in the Nth line.
All answer in the range of signed 64-bits integer.
 

 

Sample Input
3
0
1
2
 

 

Sample Output
0 1
1 8
8 27
 
找规律
#include<stdio.h>
#include<string.h>
int main()
{
	long long m,n;
	scanf("%lld",&n);
	while(n--)
	{
		scanf("%lld",&m);
		printf("%lld %lld\n",m*m*m,(m+1)*(m+1)*(m+1));
	}
	return 0;
} 

  

hdoj 1977 Consecutive sum II

原文:http://www.cnblogs.com/tonghao/p/4579378.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!