首页 > 其他 > 详细

1.A+B Format

时间:2015-06-22 11:10:14      阅读:133      评论:0      收藏:0      [点我收藏+]

Calculate a + b and output the sum in standard format — that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

/**********************************************************************     
* *   Copyright (c)2015,WK Studios   
* *   Filename:  A.h 
* *   Compiler: GCC  vc 6.0    
* *   Author:WK     
* *   Time: 2015 21 6  
* **********************************************************************/ 
#include <stdio.h>
#include <string.h>

int main ()
{
	int a, b;
	scanf("%d%d", &a, &b);
	a += b;

	if (a < 0)
	printf("-"), a = -a;

	char s[20];
	sprintf(s, "%d", a);//将数字以字符串的形式存入数组中

	for (int i = 0, len = strlen(s); s[i]; i++)
	{
		if ((len-i)%3 == 0 && i) printf(",");
		printf("%c", s[i]);
	}
	printf("\n");

	return 0;
}


1.A+B Format

原文:http://blog.csdn.net/kai8wei/article/details/46591559

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!