首页 > 其他 > 详细

HDU-3535 AreYouBusy

时间:2014-03-23 16:59:05      阅读:350      评论:0      收藏:0      [点我收藏+]

分组背包+至少一个+最多一个+随意。

包之间的传值就是把上一组的背包复制到这组背包中,达到背包之间的联系。

http://acm.hdu.edu.cn/showproblem.php?pid=3535

AreYouBusy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2676    Accepted Submission(s): 995


Problem Description
Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
What‘s more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss‘s advice)?
 

 

Input
There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.
 

 

Output
One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .
 

 

Sample Input
3 3
2 1
2 5
3 8
2 0
1 0
2 1
3 2
4 3
2 1
1 1
3 4
2 1
2 5
3 8
2 0
1 1
2 8
3 2
4 4
2 1
1 1
1 1
1 0
2 1
5 3
2 0
1 0
2 1
2 0
2 2
1 1
2 0
3 2
2 1
2 1
1 5
2 8
3 2
3 8
4 9
5 10
 

 

Sample Output
5
13
-1
-1
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
#include<iostream>
#include<cstring>
#include<cstdio>
#define Min -99999
using namespace std;
int max(int x,int y)
{
    if(x>y)
        return x;
    else
        return y;
}
int dp[200][200];
int w[200],v[200];
int main()
{
    int n,t,i,j,m,s,k;
    while(~scanf("%d%d",&n,&t))
    {
         memset(dp,0,sizeof(dp));
     for(i=1;i<=n;i++)
    {
        cin>>m>>s;
        for(j=1;j<=m;j++)
          cin>>w[j]>>v[j];
          if(s==0)
          {
              for(j=0;j<=t;j++)
               dp[i][j]=Min;
          for(j=1;j<=m;j++)
            {
                for(k=t;k>=w[j];k--)
                {
                    dp[i][k]=max( dp[i][k],dp[i][k-w[j]]+v[j]);
                    dp[i][k]=max( dp[i][k],dp[i-1][k-w[j]]+v[j]);
                }
            }
          }
          else if(s==1)
          {
              for(j=0;j<=t;j++)
                dp[i][j]=dp[i-1][j];
              for(j=1;j<=m;j++)
            {
                for(k=t;k>=w[j];k--)
                {
                    dp[i][k]=max( dp[i][k],dp[i-1][k-w[j]]+v[j]);
 
                }
            }
          }
           else
          {
              for(j=0;j<=t;j++)
                dp[i][j]=dp[i-1][j];
               for(j=1;j<=m;j++)
            {
                for(k=t;k>=w[j];k--)
                {
                    dp[i][k]=max( dp[i][k],dp[i][k-w[j]]+v[j]);
                    dp[i][k]=max( dp[i][k],dp[i-1][k-w[j]]+v[j]);
                }
            }
          }
 
    }
     if(dp[n][t]<=0)
        cout<<"-1"<<endl;
     else
        cout<<dp[n][t]<<endl;
    }
    return 0;
}

 

 

HDU-3535 AreYouBusy,布布扣,bubuko.com

HDU-3535 AreYouBusy

原文:http://www.cnblogs.com/cancangood/p/3619016.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!