首页 > 其他 > 详细

PAT: 1019. General Palindromic Number (20)

时间:2014-03-23 20:37:26      阅读:422      评论:0      收藏:0      [点我收藏+]

1019. General Palindromic Number (20)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0". Notice that there must be no extra space at the end of output.

Sample Input 1:
27 2
Sample Output 1:
Yes
1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No
4 4 1
AC代码:
//数制转换

#include<stdio.h>

int main()
{
    //freopen("in.txt","r",stdin);
	int n, b;
	scanf("%d %d",&n,&b);
	int s[100];
	int k=0;
	while(n/b) {
		s[k++] = n % b;
		n /= b;
	}
	s[k++] = n % b;
	int i, flag = 1;
	for(i=0; i<k/2; i++) {
		if(s[i] != s[k-i-1]) {
			flag = 0;
			break;
		}
	}
	if(flag)
		printf("Yes\n");
	else 
		printf("No\n");
	for(i=k-1; i>0; i--) {
		printf("%d ",s[i]);
	}
	printf("%d\n",s[i]);

    return 0;
}


PAT: 1019. General Palindromic Number (20),布布扣,bubuko.com

PAT: 1019. General Palindromic Number (20)

原文:http://blog.csdn.net/zjfclh/article/details/21873853

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!