首页 > 其他 > 详细

POJ 1426 Find The Multiple

时间:2014-03-23 23:28:56      阅读:669      评论:0      收藏:0      [点我收藏+]

看了输出数据会达到100个数字,想到肯定高精度了,然后就百度了,没想到__int64 就可以水过,果断暴力bfs,直到找到解。


Find The Multiple
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 16582   Accepted: 6758   Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111




以下是代码,希望有大神看到此代码 然后指点一下如果数据强了,怎么解决。


#include<stdio.h>
#include<string.h>
int n;
__int64 q[10010000];
void bfs()
{
    int front=0,rear=0;
    q[rear++]=1;
    while(front<rear)
    {
        __int64 d=q[front++];
        if(d%n==0)
        {
            printf("%I64d\n",d);
            return;
        }
        __int64 nd=10*d;
        q[rear++]=nd;
        q[rear++]=nd+1;
    }
}
int main()
{
    while(~scanf("%d",&n) && n)
    {
        bfs();
    }
    return 0;
}



POJ 1426 Find The Multiple,布布扣,bubuko.com

POJ 1426 Find The Multiple

原文:http://blog.csdn.net/u013923947/article/details/21888213

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!