A^B Problem
时间限制:1000 ms | 内存限制:65535 KB
难度:2
-
描述
- Give you two numbers a and b,how to know the a^b‘s the last digit number.It looks so easy,but everybody is too lazy to slove this problem,so they remit to you who is wise.
-
输入
- There are mutiple test cases. Each test cases consists of two numbers a and b(0<=a,b<2^30)
-
输出
- For each test case, you should output the a^b‘s last digit number.
-
样例输入
-
7 66
8 800
-
样例输出
-
9
6
-
提示
- There is no such case in which a = 0 && b = 0。
-
来源
- hdu
-
上传者
- ACM_丁国强
#include <stdio.h>
int main()
{
int a,b,_a,s;
while(scanf("%d %d",&a,&b)!=EOF)
{
if(a==0&&b==0)
break;
s=1;
while(b)
{
if(s>=10)
s=s%10;
if(a>=10)
a=a%10;
if(b%2==1)
s=s*a;
a=a*a;
b=b/2;
}
if(s>=10)
s=s%10;
printf("%d\n",s);
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
nyoj473 A^B Problem (快速幂)
原文:http://blog.csdn.net/su20145104009/article/details/46770453