首页 > 其他 > 详细

PAT 1005. Spell It Right (20)

时间:2015-07-12 20:07:31      阅读:274      评论:0      收藏:0      [点我收藏+]

1005. Spell It Right (20)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five

 

#include <iostream>
#include <vector>
#include <map>
#include <string>

using namespace std;

string spell(int digit)
{
    if(digit==0)
        return "zero";
    else if(digit==1)
        return "one";
    else if(digit==2)
        return "two";
    else if(digit==3)
        return "three";
    else if(digit==4)
        return "four";
    else if(digit==5)
        return "five";
    else if(digit==6)
        return "six";
    else if(digit==7)
        return "seven";
    else if(digit==8)
        return "eight";
    else if(digit==9)
        return "nine";
}

int main()
{
    string num;
    int sum=0;
    string res;

    cin >> num;
    for(int i=0;i<num.size();i++)
        sum += (num[i]-0);
    int digit = sum%10;
    sum /= 10;
    res = spell(digit) + res;

    while(sum!=0)
    {
        digit = sum%10;
        sum /=10;
        res = spell(digit) + " " + res;
    }

    cout << res;

}

 

PAT 1005. Spell It Right (20)

原文:http://www.cnblogs.com/jackwang822/p/4641425.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!