首页 > 其他 > 详细

hdu 4496 D-City(并查集)

时间:2015-07-13 14:02:13      阅读:232      评论:0      收藏:0      [点我收藏+]

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2448    Accepted Submission(s): 862


Problem Description
Luxer is a really bad guy. He destroys everything he met. 
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input. 
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 

Input
First line of the input contains two integers N and M. 
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line. 
Constraints: 
0 < N <= 10000 
0 < M <= 100000 
0 <= u, v < N. 
 

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 

Sample Input
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 

Sample Output
1 1 1 2 2 2 2 3 4 5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there‘s only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  5283 5282 5280 5279 5278 
 

题意:给你一个n个点的图,任意两点之间都有一条无向边,然后Q个查询

          每个查询求删除一条边后剩下多少块。

题解:边删完了块数肯定是n,所以我们可以从后面开始,一次加入边,然后求块数。

#include<cstring>
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<vector>
#define N 10010
#define M 100100
#define ll long long

using namespace std;

int par[N];
int r[N];
int s[M];
int n,m;

struct node {
    int x,y;
} a[M];

void init() {
    for(int i=0; i<=n; i++) {
        par[i]=i;
        r[i]=0;
    }
}

int finds(int x) {
    if(par[x]==x)return x;
    return par[x]=finds(par[x]);
}

void unite(int x,int y) {
    x=finds(x);
    y=finds(y);
    if(x==y)return;
    if(r[x]<r[y]) {
        par[x]=y;
    } else {
        par[y]=x;
        if(r[x]==r[y])r[x]++;
    }
}

bool same(int x,int y) {
    return finds(x)==finds(y);
}

int main() {
    //freopen("test.in","r",stdin);
    while(cin>>n>>m) {
        for(int i=0; i<m; i++) {
            scanf("%d%d",&a[i].x,&a[i].y);
        }
        init();
        int ans=n;
        for(int i=m-1; i>=0; i--) {
            s[i]=ans;
            int x=a[i].x,y=a[i].y;
            if(!same(x,y)) {
                ans--;
            }
            unite(x,y);
        }
        for(int i=0; i<m; i++) {
            printf("%d\n",s[i]);
        }
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 4496 D-City(并查集)

原文:http://blog.csdn.net/acm_baihuzi/article/details/46861325

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!