首页 > 其他 > 详细

Bestcoder #47 B Senior's Gun

时间:2015-07-14 15:34:15      阅读:371      评论:0      收藏:0      [点我收藏+]

Senior‘s Gun

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 875    Accepted Submission(s): 319


Problem Description
Xuejiejie is a beautiful and charming sharpshooter.

She often carries n guns, and every gun has an attack power a[i].

One day, Xuejiejie goes outside and comes across m monsters, and every monster has a defensive power b[j].

Xuejiejie can use the gun i to kill the monster j, which satisfies b[j]a[i], and then she will get a[i]?b[j] bonus .

Remember that every gun can be used to kill at most one monster, and obviously every monster can be killed at most once.

Xuejiejie wants to gain most of the bonus. It‘s no need for her to kill all monsters.
 

Input
In the first line there is an integer T, indicates the number of test cases.

In each case:

The first line contains two integers nm.

The second line contains n integers, which means every gun‘s attack power.

The third line contains m integers, which mean every monster‘s defensive power.

1n,m100000?109a[i],b[j]109
 

Output
For each test case, output one integer which means the maximum of the bonus Xuejiejie could gain.
 

Sample Input
1 2 2 2 3 2 2
 

Sample Output
1
 

Source

BestCoder Round #47 ($)



#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
using namespace std;

__int64  a[100005],b[100005];

int cmp(int x,int y)
{
    return x>y;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);

//        memset(a,0,sizeof(a));

        for(int i = 0;i < n; i++)
            scanf("%I64d",&a[i]);
        for(int i = 0;i < m; i++)
            scanf("%I64d",&b[i]);

        sort(a,a+n,cmp);
        sort(b,b+m);
        __int64 sum = 0;

        for(int i = 0;i < n; i++)
        {
            if(a[i] > b[i] &&i < m)
                sum += (a[i] - b[i]);
            //printf("%d ",a[i] - b[i]);
        }

        printf("%I64d\n",sum);
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Bestcoder #47 B Senior's Gun

原文:http://blog.csdn.net/u012349696/article/details/46878029

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!