首页 > 其他 > 详细

Acdream 1115——找规律——Salmon And Cat

时间:2015-07-15 22:38:36      阅读:200      评论:0      收藏:0      [点我收藏+]

Math is very important, for those who are also in school, make sure you will learn more about math.

Salmon and Cat are good friends.Today Salmon ask Cat to help her judge whether a number is perfect or not. Perfect number is a kind of number defined by like this.

First, 1 and 3 are perfect number.Then if a and b are perfect numbers, 2+ab+2a+2b is also a perfect number.For example, 1 and 1 are perfect numbers,  so 2+1+2+2 = 7 is perfect number.

If Cat can‘t help Salmon,  Salmon will be sad and Cat will be much more sad. So Cat must solve the problem to maintain their friendship. Can you help Cat to solve the problem?

Input

This problem contains multiple test cases.

Each test case contains one line.

Each line contains an interger n, 1 ≤ n ≤ 109.

Output

For each test case, if n is a perfect number, output “Yes”, otherwise output “No”.

Sample Input

3
7
8

Sample Output

Yes
Yes
No

Hint

/*
   找规律..
   所有数都是3或5之积
*/
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
    int n;
    while(~scanf("%d", &n)){
        n += 2;
        while(n % 3 == 0) n/= 3;
        while(n % 5 == 0) n/= 5;
        if(n == 1) printf("Yes\n");
        else printf("No\n");
    }
return 0;
}
            

  

Acdream 1115——找规律——Salmon And Cat

原文:http://www.cnblogs.com/zero-begin/p/4649587.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!