首页 > 其他 > 详细

Compound Words

时间:2015-07-19 23:09:13      阅读:265      评论:0      收藏:0      [点我收藏+]

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is theconcatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line,in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, inalphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

 

Sample Output

alien
newborn


AC代码:
#include"iostream"
#include"set"
using namespace std;
int main()
{
    set<string> dic;
    string s;
    while(cin>>s) dic.insert(s);
    set<string> ::iterator it;
    for(it=dic.begin();it!=dic.end();it++)
    {
     string str,sub1,sub2;
     str=*it;
     for(int i=0;i<str.size()-1;i++)
     {
         sub1=str.substr(0,i+1);
         sub2=str.substr(i+1,str.size()-i-1);
         if(dic.find(sub1)!=dic.end()&&dic.find(sub2)!=dic.end())
         {
            cout<<str<<endl;
            break;     //一定要即时break掉,以免重复
         }
     }


    }
    return 0;
}

Compound Words

原文:http://www.cnblogs.com/zsyacm666666/p/4659949.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!