首页 > 其他 > 详细

bestcoder 47# wyh2000 and a string problem (水题)

时间:2015-07-20 09:15:34      阅读:108      评论:0      收藏:0      [点我收藏+]

wyh2000 and a string problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 484    Accepted Submission(s): 232


Problem Description
Young theoretical computer scientist wyh2000 is teaching young pupils some basic concepts about strings.

A subsequence of a string s is a string that can be derived from s by deleting some characters without changing the order of the remaining characters. You can delete all the characters or none, or only some of the characters.

He also teaches the pupils how to determine if a string is a subsequence of another string. For example, when you are asked to judge whether wyh is a subsequence of some string or not, you just need to find a character w, a y, and an h, so that the w is in front of the y, and the y is in front of the h.

One day a pupil holding a string asks him, "Is wyh a subsequence of this string?"
However, wyh2000 has severe myopia. If there are two or more consecutive character vs, then he would see it as one w. For example, the string vvv will be seen asw, the string vvwvvv will be seen as www, and the string vwvv will be seen as vww.

How would wyh2000 answer this question?
 

Input
The first line of the input contains an integer T(T105), denoting the number of testcases.

N lines follow, each line contains a string.

Total string length will not exceed 3145728. Strings contain only lowercase letters.

The length of hack input must be no more than 100000.
 

Output
For each string, you should output one line containing one word. Output Yes if wyh2000 would consider wyh as a subsequence of it, or No otherwise.
 

Sample Input
4 woshiyangli woyeshiyangli vvuuyeh vuvuyeh
 

Sample Output
No Yes Yes No
 

Source
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
char s[40000000];
char str[5]={"wyh"};
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",s);

        int len = strlen(s);

        int id=0;

        for(int i = 0;i < len;i++)
        {
            if(id==3) break;
            if(s[i]==str[id]) id++;
            if(id==0 && s[i]=='v' && s[i+1]=='v') id++;
        }
//        printf("%d\n",id);
        if(id==3) printf("Yes\n");
        else printf("No\n");
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

bestcoder 47# wyh2000 and a string problem (水题)

原文:http://blog.csdn.net/u012349696/article/details/46963663

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!