首页 > 其他 > 详细

PAT-ADVANCED-1001-A+B Format

时间:2015-07-20 22:45:45      阅读:124      评论:0      收藏:0      [点我收藏+]

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

 

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

 将a+b的和从低到高,三位的隔开.

在这里我们直接使用stack来存储,需要注意res=0的情况;输出第一个和剩下来的补全问题

技术分享
#include <bits/stdc++.h>
#define LL long long
#define MAXN 100000+50
#define MOD 1000000007
using namespace std;


stack<int> s;
int  main(){
    int res, a, b;
    scanf("%d%d", &a, &b);
    res = a+b;
    if(!res){
        printf("0");
        return 0;
    }
    if(res < 0){
        printf("-");
        res = -res;
    }
    while(res){
        s.push(res%1000);
        res /= 1000;
    }
    bool flag = false;
    while(!s.empty()){
        if(!flag){
            printf("%d", s.top());
            s.pop();
            flag = true;
        }
        else{
            printf(",%03d", s.top());
            s.pop();
        }
    }
    return 0;
}
CAPOUIS‘CODE

 

PAT-ADVANCED-1001-A+B Format

原文:http://www.cnblogs.com/capouis/p/4662616.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!