首页 > 其他 > 详细

POJ 2785 4 Values whose Sum is 0 (对半分解 二分搜索)

时间:2015-07-27 21:10:55      阅读:182      评论:0      收藏:0      [点我收藏+]


4 Values whose Sum is 0
Time Limit: 15000MS   Memory Limit: 228000K
Total Submissions: 17658   Accepted: 5187
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

Source

Southwestern Europe 2005

题目链接:http://poj.org/problem?id=2785

题目大意:给四组数,一列为一组,从每组中取一个出来使得四个相加为0,问有多少种方案

题目分析:a + b + c + d = 0  ==> a + b = -c -d,我们先预处理出前两组能组成的值,复杂度为n^2,然后排序后二分查找,这里最简便的方法是分别求出upper_bound(num, num + cnt, -c-d) - num,lower_bound(num, num + cnt, -c-d) - num,前者表示num数组里大于-c-d的第一个位置,后者表示num数组里大于等于-c-d的第一个位置,然后一减就得到与-c-d相等的个数

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>
#include <iostream>
#define ll long long
using namespace std;
int const MAX = 4e3 + 5;
int a[MAX], b[MAX], c[MAX], d[MAX];
int num[MAX * MAX];

int main()
{   
    int n;
    while(scanf("%d", &n) != EOF)
    {
        ll ans = 0;
        int cnt = 0;
        for(int i = 1; i <= n; i++)
            scanf("%d %d %d %d", &a[i], &b[i], &c[i], &d[i]);
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++)
                num[cnt ++] = a[i] + b[j];
        sort(num, num + cnt);
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                int tmp = -c[i] - d[j];
                int t1 = lower_bound(num, num + cnt, tmp) - num;
                int t2 = upper_bound(num, num + cnt, tmp) - num;
                ans += (ll)(t2 - t1);
            }
        }
        cout << ans << endl;
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 2785 4 Values whose Sum is 0 (对半分解 二分搜索)

原文:http://blog.csdn.net/tc_to_top/article/details/47088987

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!