首页 > 其他 > 详细

HDU--1061

时间:2015-07-27 23:11:37      阅读:310      评论:0      收藏:0      [点我收藏+]

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39389    Accepted Submission(s): 14863


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
2 3 4
 

Sample Output
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 

Author
Ignatius.L
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;

long long int powermod(long long int a,long long int b,long long int c)
{
    long long int ans = 1;
    a = a%c;
    while (b > 0)
    {
        if (b% 2 ==1)
            ans = ans * a %c;
        b = b/2;
        a = a* a %c;
    }
    return ans;
}

int main()
{
    int t;
    long long int n;
    cin >> t;
    while (t--)
    {
        cin >> n;
        cout <<powermod(n,n,10) << endl;
    }
    return 0;
}

快速幂求余!

版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU--1061

原文:http://blog.csdn.net/xiaotan1314/article/details/47090737

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!