Moving Tables
Time Limit : 2000/1000ms (Java/Other) Memory Limit :
65536/32768K (Java/Other)
Total Submission(s) : 21 Accepted Submission(s) : 11
Font: Times New Roman | Verdana |
Georgia
Font Size: ← →
Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a
floor of a building whose shape is in the following figure.
The floor
has 200 rooms each on the north side and south side along the corridor.
Recently the Company made a plan to reform its system. The reform includes
moving a lot of tables between rooms. Because the corridor is narrow and all
the tables are big, only one table can pass through the corridor. Some plan is
needed to make the moving efficient. The manager figured out the following
plan: Moving a table from a room to another room can be done within 10 minutes.
When moving a table from room i to room j, the part of the corridor between the
front of room i and the front of room j is used. So, during each 10 minutes,
several moving between two rooms not sharing the same part of the corridor will
be done simultaneously. To make it clear the manager illustrated the possible
cases and impossible cases of simultaneous moving.
For
each room, at most one table will be either moved in or moved out. Now, the
manager seeks out a method to minimize the time to move all the tables. Your
job is to write a program to solve the manager’s problem.
Input
The input consists of T test cases. The number of test cases
) (T is given in the first line of the input. Each test case begins with a line
containing an integer N , 1<=N<=200 , that represents the number of
tables to move. Each of the following N lines contains two positive integers s
and t, representing that a table is to move from room number s to room number t
(each room number appears at most once in the N lines). From the N+3-rd line,
the remaining test cases are listed in the same manner as above.
Output
The output should contain the minimum time in minutes to
complete the moving, one per line.
Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
Sample Output
10
20
30
题意:
要你搬桌子,有重叠的区域段不能同时搬,不重叠可以同时。每次搬桌子需要10分钟,问你最少用多长时间。
注意:
1.判断首尾,一开始就比较下,小的为start,大的为end。
if(start>end){/*要判断头尾*/
t=end;
end=start;
start=t;
}
2.由于(1,2)(3,4)。。。这种属于同一区段,因此简化下,就是( +1)/2,将区域划分,因为偶数加上没影响,所以可以不判断都直接计算。
start=(start+1)/2;
end=(end+1)/2;
3.核心算法:贪心:哪个区域的经过次数最多,该次数就是我们所求取得数值;
for(j=start;j<=end;j++)
a[j]++;
4.排序,排序后得到最大即:最繁忙的区域段 sort(a,a+201,cmp);(由大到小)
5.输出时,不要忘了*10。
代码:
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
#include<string.h>
bool cmp(int a,int b)
{
if (a>b) return true;
return false;
}
int main(){
int T,a[201],n,t;
int i,start,end,j;
while(scanf("%d",&T)!=EOF){
while(T--){
memset(a,0,sizeof(a));/*头文件是<string.h>*/
scanf("%d",&n);
for(i=0;i<n;i++){
scanf("%d%d",&start,&end);
if(start>end){/*要判断头尾*/
t=end;
end=start;
start=t;
}
start=(start+1)/2;
end=(end+1)/2;
for(j=start;j<=end;j++)
a[j]++;
}
sort(a,a+201,cmp);
printf("%d\n",a[0]*10);
}
}
return 0;
}
Moving Tables,布布扣,bubuko.com
Moving Tables
原文:http://www.cnblogs.com/money-lady/p/3650685.html