链接:http://poj.org/problem?id=2155
Description
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1
<= i, j <= N).
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a ‘0‘ then change it into ‘1‘ otherwise change
it into ‘0‘). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].
Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above.
Output
For each querying output one line, which has an integer representing A[x, y].
There is a blank line between every two continuous test cases.
Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1
Sample Output
1
0
0
1
代码如下:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#define MAXN 1050
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;
int map[MAXN][MAXN], cas;
int N, M, x1, y1, x2, y2, Mc, Md;
char ch;
int lowbit(int x) { return x & (-x); }
void Init() { scanf("%d %d", &N, &M); RST(map); }
void update(int x, int y, int d) //二维树状数组的更新(从大到小);
{
while(y > 0) {
int Mx = x;
while(Mx > 0) {
map[Mx][y] += d;
Mx -= lowbit(Mx);
}
y -= lowbit(y);
}
}
int getsum(int x, int y) //二维树状数组的求和(从小到大);
{
int sum = 0;
while(y <= N) {
int Mx = x;
while(Mx <= N) {
sum += map[Mx][y];
Mx += lowbit(Mx);
}
y += lowbit(y);
}
return sum;
}
int main()
{
scanf("%d", &cas);
while(cas--) {
Init();
while(M--) {
getchar();
scanf("%c", &ch);
if(ch == ‘C‘) {
scanf("%d %d %d %d", &x1, &y1, &x2, &y2);
update(x2, y2, 1);
update(x1-1, y2, -1);
update(x1-1, y1-1, 1);
update(x2, y1-1, -1);
}else if(ch == ‘Q‘) {
scanf("%d %d", &Mc, &Md);
int res = getsum(Mc, Md)%2;
printf("%d\n", res);
}
}
if(cas) puts("");
}
return 0;
}
POJ 2155 Matrix (二维树状数组),布布扣,bubuko.com
POJ 2155 Matrix (二维树状数组)
原文:http://blog.csdn.net/keshacookie/article/details/23270499