首页 > 其他 > 详细

题目1001:A+B for Matrices

时间:2014-03-17 00:09:04      阅读:597      评论:0      收藏:0      [点我收藏+]
题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.

输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5
来源:

2011年浙江大学计算机及软件工程研究生机试真题

AC代码:

//本题关键在于读懂题意:
//将两个同型矩阵相加后,统计为0的行数(该行所有元素都为0)和列数

#include<stdio.h>
#define N 10

int matrices[N][N]; //存储矩阵

int main() {
	//freopen("in.txt","r",stdin);
	int m, n, num;
	while(scanf("%d %d",&m,&n)!=EOF && m) {
		int i, j, a;
		for(i=0; i<m; i++)
			for(j=0; j<n; j++)
				scanf("%d",&matrices[i][j]); //读入第一个矩阵
		for(i=0; i<m; i++) {
			for(j=0; j<n; j++) {
				scanf("%d",&a);
				matrices[i][j] += a; //为了节省空间,直接在原来的矩阵上进行相加
			}
		}
		num = m + n; //假设所有行和列都为0,num用来存储0行和0列总数
		for(i=0; i<m; i++) {
			for(j=0; j<n; j++) {
				if(matrices[i][j] != 0) { //若该行有一个数不为0,则num减一
					num--;
					break;
				}
			}
		}
		for(i=0; i<n; i++) {
			for(j=0; j<m; j++) {
				if(matrices[j][i] != 0) { //若该列有一个数不为0,则num减一
					num--;
					break;
				}
			}
		}
		printf("%d\n",num);
	}

	return 0;
}


题目1001:A+B for Matrices,布布扣,bubuko.com

题目1001:A+B for Matrices

原文:http://blog.csdn.net/zjfclh/article/details/21339769

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!